プラグインをアップデートしたり、新しくプラグインを入れようとしたらこんなエラーが出ました。

「WordPress.org かこのサーバーの設定で何かがうまくいっていないようです。・・・・ wp-includes/update.php」

早速ググって調べると、

アップデートする時、FTP接続時にSSL接続にするようになっているためのようです。

別に何も変えなくても動作は問題ないのですが見かけ上嫌なので改善しました。

ワードプレスのソースファイルの中にあるupdate.phpを変更。

変更前

if ( $ssl = wp_http_supports( array( ‘ssl’ ) ) )
$url = set_url_scheme( $url, ‘https’ );

変更後

// if ( $ssl = wp_http_supports( array( ‘ssl’ ) ) )
// $url = set_url_scheme( $url, ‘https’ );

この修正によりエラーメッセージは消えました。

次のWordPressのアップデートで改善されるといいですね。じゃないと、アップデートする度にこの修正をやらないくてはいけなくなってしまうかと(^^;。

参考http://blog.communes.jp/honoka/wp/archives/2457

Related Post